Android

SDK

Version 2.160 (July 1, 2020)
Changes:
Improved the stability of the library for various devices.
Version 2.150 (May 27, 2020)
Changes:
Improved the stability of the library for various devices.
Version 2.143 (May 18, 2020)
Changes:
Improved the display of the native ad integration indicator.
Version 2.142 (April 17, 2020)
Changes:
Improved the stability of the library for various devices.
Version 2.141 (April 8, 2020)
Changes:
Improved the stability of the library for various devices.
Version 2.140 (March 25, 2020)
Additions:
Added support for loading an ad block with multiple native ads.
Version 2.130 (March 18, 2020)
Changes:
Improved the stability of the library for various devices.
Additions:
Added support for a new type of banner size: stickySize.
Version 2.120 (March 5, 2020)
Changes:
  • Faster loading and display of native ads.
  • The recommended version of AppMetrica is 3.13.1.
Version 2.113 (January 17, 2020)
Changes:
Improved the stability of the library for various devices.
Version 2.112 (December 20, 2019)
Changes:
Improved the stability of the library for various devices.
Fixes:
Fixed the display of the native ad integration indicator.
Version 2.111 (November 6, 2019)
Changes:
  • Improved the stability of the library for various devices.
  • Optimized RAM usage.
Version 2.110 (October 22, 2019)
Additions:
Added an integration indicator for native ads in debugging mode.
Changes:
Fixes:
Fixed the error with View reuse in native ads.
Version 2.101 (August 23, 2019)
Changes:
  • Improved the stability of the library for various devices.
  • Fixed the lint error.
Version 2.100 (June 27, 2019)
Changes:
  • Improved the stability of the library for various devices.
  • The recommended version of AppMetrica is 3.6.4.
Version 2.91 (May 24, 2019)
Additions:
Video support in native ad mediation.
Changes:
Improved the stability of the library for various devices.
Version 2.90 (May 23, 2019)
Additions:
Version 2.81 (March 7, 2019)
Changes:
Improved the stability of the library for various devices.
Version 2.80 (December 14, 2018)
Additions:
Version 2.75 (October 1, 2018)
Changes:
  • Improved the stability of the library for various devices.
  • Recommended version of AppMetrica: 3.2.2 and later.
Version 2.74 (September 14, 2018)
Changes:
Improved the stability of the library for various devices.
Version 2.73 (August 17, 2018)
Changes:
Improved the stability of the library for various devices.
Version 2.72 (May 29, 2018)
Changes:
Improved the stability of the library for various devices.
Version 2.71 (April 20, 2018)
Additions:
Added native ad mediation when working with ADFOX.
Changes:
Fixed excessive memory consumption when working with videos in interstitial ads.
Version 2.70 (February 5, 2018)
Additions:
  • Added support for videos in interstitial (full-screen) ads.
  • Now you can use the SDK without activating the AppMetrica SDK.
  • Added feedback support to native ads (offers a selection of reasons when the user closes an ad).
Version 2.62 (November 13, 2017)
Changes:
Improved the stability of the library for various devices.
Version 2.61 (August 31, 2017)
Changes:
Improved the stability of the library for various devices.
Version 2.60 (June 23, 2017)
Changes:
Improved the stability of the library for various devices.
Version 2.51 (April 18, 2017)
Changes:
Improved the stability of the library for various devices.
Version 2.50 (January 20, 2017)
Additions:
Added the Image type of native ads for working with ADFOX.
Version 2.31 (September 24, 2016)
Changes:
Improved the stability of the library for various devices.
Version 2.30 (August 22, 2016)
Changes:
Improved the stability of the library for various devices.
Version 2.20 (July 20, 2016)
Additions:
Changes:
Changed the process for loading native ads.
Version 2.13 (June 20, 2016)
Changes:
Improved the stability of the library for various devices.
Version 2.12 (May 13, 2016)
Changes:
Improved the stability of the library for various devices.
Version 2.11 (April 26, 2016)
Changes:
  • Improved the stability of the library for various devices.
  • Fixed the AdMob adapter.
  • The minimum supported AppMetrica version is 2.40 or later.
Version 2.10 (April 7, 2016)
Additions:
Added a layout template for native ads.

Mobile Ads SDK adapters for ad networks

  1. AdMob
  2. MoPub

AdMob

Version 0.4.0 (May 2, 2020)
Changes:
The minimum supported version of the Play Services Ads SDK is 19.1.0.
Version 0.3.0 (April 17, 2020)
Changes:
The minimum supported version of the Play Services Ads SDK is 19.0.1.
Version 0.2.0 (November 11, 2019)
Changes:
  • The minimum supported version of the Play Services Ads SDK is 18.2.0.
  • The recommended version of AppMetrica is 3.8.0.
Version 0.1.2 (October 23, 2019)
Changes:
The minimum supported version of the Play Services Ads SDK is 17.1.3.
Additions:
Added support for the Yandex Mobile Ads SDK 2.110.
Version 0.1.1 (August 23, 2019)
Changes:
Improved the stability of the library for various devices.
Additions:
Added support for the Yandex Mobile Ads SDK 2.101.

MoPub

Version 0.2.0 (July 1, 2020)
Changes:
The minimum supported version of the MoPub SDK is 5.13.0.
Version 0.1.2 (October 23, 2019)
Additions:
Added support for NativeAdViewBinder.
Changes:
  • Improved data syncing for counted impressions in the MoPub mediation interface.
  • The recommended version of AppMetrica is 3.8.0.
Additions:
Added support for the Yandex Mobile Ads SDK 2.110.
Version 0.1.1 (August 23, 2019)
Changes:
  • The minimum supported version of the MoPub SDK is 5.7.0.
  • The recommended version of AppMetrica is 3.6.4.
Additions:
Added support for the Yandex Mobile Ads SDK 2.101.
Version 0.1.0 (June 24, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.91.

Mobile mediation adapters

  1. AdMob
  2. myTarget
  3. MoPub
  4. Facebook
  5. StartApp
  6. UnityAds
  7. AppLovin
  8. IronSource

AdMob

Version 1.12.0 (July 30, 2020)
Changes:
The minimum supported version of the Play Services Ads SDK is 19.3.0.
Version 1.11.0 (July 1, 2020)
Changes:
Improved the stability of the library for various devices.
Version 1.10.0 (May 25, 2020)
Changes:
Improved the stability of the library for various devices.
Version 1.9.0 (May 2, 2020)
Changes:
The minimum supported version of the Play Services Ads SDK is 19.1.0.
Version 1.8.0 (March 27, 2020)
Changes:
The minimum supported version of the Play Services Ads SDK is 19.0.1.
Version 1.7.0 (December 20, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.112.
Changes:
The minimum supported version of the Play Services Ads SDK is 18.3.0.
Version 1.6.0 (November 13, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.111.
Changes:
  • The minimum supported version of the Play Services Ads SDK is 18.2.0.
  • The recommended version of AppMetrica is 3.8.0.
Version 1.5.0 (July 19, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.100.
Changes:
  • The minimum supported version of the Play Services Ads SDK is 17.2.0.
  • The recommended version of AppMetrica is 3.6.4.
Version 1.4.0 (May 23, 2019)
Additions:
Added support for media ads in native advertising.
Changes:
The minimum supported version of the Play Services Ads SDK is 17.1.3.
Version 1.3.0 (February 28, 2019)
Changes:
The minimum supported version of the Play Services Ads SDK is 17.1.2.
Version 1.2.0 (December 14, 2018)
Changes:
Improved the stability of the library for various devices.

myTarget

Version 1.8.0 (July 30, 2020)
Changes:
  • The minimum supported version of the myTarget SDK is 5.9.1.
  • Improved the stability of the library for various devices.
Version 1.7.0 (May 25, 2020)
Changes:
  • The minimum supported version of the myTarget SDK is 5.8.0.
  • Improved the stability of the library for various devices.
Version 1.6.0 (May 2, 2020)
Changes:
The minimum supported version of the myTarget SDK is 5.7.1.
Version 1.5.0 (March 5, 2020)
Additions:
Added support for the Yandex Mobile Ads SDK 2.120.
Changes:
The minimum supported version of the myTarget SDK is 5.6.0.
Version 1.4.0 (January 17, 2020)
Additions:
Added support for the Yandex Mobile Ads SDK 2.113.
Changes:
The minimum supported version of the myTarget SDK is 5.5.6.
Version 1.3.0 (July 17, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.100.
Changes:
  • The minimum supported version of the myTarget SDK is 5.4.5.
  • The recommended version of AppMetrica is 3.6.4.
Version 1.2.0 (May 24, 2019)
Additions:
Added support for media ads in native advertising.
Changes:
The minimum supported version of the myTarget SDK is 5.3.4.
Version 1.1.0 (December 19, 2018)
Changes:
  • Improved the stability of the library for various devices.
  • Minimum supported version of myTarget SDK: 5.2.4 and later.
Version 1.0.1 (September 22, 2018)
Changes:
Improved the stability of the library for various devices.

MoPub

Version 1.7.0 (May 25, 2020)
Changes:
Improved the stability of the library for various devices.
Version 1.6.0 (April 17, 2020)
Changes:
The minimum supported version of the MoPub SDK is 5.12.0.
Version 1.5.0 (March 5, 2020)
Additions:
Added support for the Yandex Mobile Ads SDK 2.120.
Changes:
The minimum supported version of the MoPub SDK is 5.11.1.
Version 1.4.0 (December 20, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.112.
Changes:
The minimum supported version of the MoPub SDK is 5.10.0.
Version 1.3.0 (July 19, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.100.
Version 1.2.0 (May 24, 2019)
Changes:
Improved the stability of the library for various devices.
Version 1.1.0 (May 23, 2019)
Additions:
Added support for media ads in native advertising.
Changes:
The minimum supported version of the MoPub SDK is 5.7.0.
Version 1.0.1 (October 1, 2018)
Changes:
Improved the stability of the library for various devices.

Facebook

Version 1.10.0 (July 30, 2020)
Additions:
The minimum supported version of the Facebook Audience Network SDK is 5.10.1.
Changes:
Improved the stability of the library for various devices.
Version 1.9.0 (May 25, 2020)
Additions:
The minimum supported version of the Facebook Audience Network SDK is 5.9.0.
Changes:
Improved the stability of the library for various devices.
Version 1.8.0 (April 17, 2020)
Changes:
The minimum supported version of the Facebook Audience Network SDK is 5.8.0.
Version 1.7.0 (March 5, 2020)
Additions:
Added support for the Yandex Mobile Ads SDK 2.120.
Changes:
The minimum supported version of the Facebook Audience Network SDK is 5.7.1.
Version 1.6.0 (January 17, 2020)
Additions:
Added support for the Yandex Mobile Ads SDK 2.113.
Changes:
The minimum supported version of the Facebook Audience Network SDK is 5.6.1.
Version 1.5.0 (December 20, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.112.
Changes:
  • The minimum supported version of the Facebook Audience Network SDK is 5.6.0.
  • The recommended version of AppMetrica is 3.8.0.
Version 1.4.0 (July 19, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.100.
Changes:
The recommended version of AppMetrica is 3.6.4.
Version 1.3.0 (May 24, 2019)
Changes:
Improved the stability of the library for various devices.
Version 1.2.0 (May 23, 2019)
Additions:
Added support for media ads in native advertising.
Changes:
The minimum supported version of the Facebook Audience Network SDK is 5.2.1.
Version 1.1.0 (December 14, 2018)
Changes:
Improved the stability of the library for various devices.

StartApp

Version 1.8.0 (June 6, 2020)
Changes:
The minimum supported version of the StartApp SDK is 4.6.0.
Version 1.7.0 (May 25, 2020)
Changes:
Improved the stability of the library for various devices.
Version 1.6.0 (April 17, 2020)
Changes:
The minimum supported version of the StartApp SDK is 4.5.0.
Version 1.5.0 (March 27, 2020)
Changes:
The minimum supported version of the StartApp SDK is 4.4.1.
Version 1.4.0 (January 17, 2020)
Additions:
Added support for the Yandex Mobile Ads SDK 2.113.
Changes:
The minimum supported version of the StartApp SDK is 4.3.2.
Version 1.3.0 (July 19, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.100.
Changes:
The recommended version of AppMetrica is 3.6.4.
Version 1.2.0 (May 24, 2019)
Additions:
Added support for media ads in native advertising.
Changes:
The minimum supported version of the StartApp SDK is 3.12.3.
Version 1.1.0 (December 14, 2018)
Changes:
Improved the stability of the library for various devices.

UnityAds

Version 1.2.0 (January 17, 2020)
Additions:
Added support for the Yandex Mobile Ads SDK 2.113.
Changes:
The minimum supported version of the Unity Ads SDK is 3.4.0
Version 1.1.0 (July 17, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.100.
Changes:
The recommended version of AppMetrica is 3.6.4.
Version 1.0.0 (April 22, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.81.

AppLovin

Version 0.6.0 (July 30, 2020)
Changes:
The minimum supported version of the AppLovin SDK is 9.13.1.
Version 0.5.0 (May 25, 2020)
Changes:
Improved the stability of the library for various devices.
Version 0.4.0 (April 17, 2020)
Changes:
The minimum supported version of the AppLovin SDK is 9.12.0.
Version 0.3.0 (January 17, 2020)
Additions:
Added support for the Yandex Mobile Ads SDK 2.113.
Changes:
The minimum supported version of the AppLovin SDK is 9.11.1.
Version 0.2.0 (December 20, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.112.
Changes:
  • The minimum supported version of the AppLovin SDK is 9.10.3.
  • The recommended version of AppMetrica is 3.8.0.
Version 0.1.0 (December 10, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.111.

IronSource

Version 0.7.0 (July 1, 2020)
Changes:
The minimum supported version of the IronSource SDK is 6.17.0.
Version 0.6.0 (April 17, 2020)
Changes:
The minimum supported version of the IronSource SDK is 6.16.0.
Version 0.5.0 (March 27, 2020)
Changes:
The minimum supported version of the IronSource SDK is 6.15.0.1.
Version 0.4.0 (March 5, 2020)
Additions:
Added support for the Yandex Mobile Ads SDK 2.120.
Changes:
The minimum supported version of the IronSource SDK is 6.14.0.1.
Version 0.3.0 (January 17, 2020)
Additions:
Added support for the Yandex Mobile Ads SDK 2.113.
Changes:
The minimum supported version of the IronSource SDK is 6.13.0.1.
Version 0.2.0 (December 20, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.112.
Changes:
  • The minimum supported version of the IronSource SDK is 6.11.0.
  • The recommended version of AppMetrica is 3.8.0.
Version 0.1.0 (December 10, 2019)
Additions:
Added support for the Yandex Mobile Ads SDK 2.111.